release: github.com/cloudfoundry/uaa-release / 28

Github source: bab79ce4 or master branch

There is a very specific upgrade incompatibility going from V24.6 to V28 of UAA Release. This doesn’t affect any cf-release upgrades as no cf-release release contains V24.6 version of UAA Release.

Stand-alone UAA-Release customers upgrading v24.6 should use V29 Instead.

Upload this release version to the Director:

$ bosh upload-release https://bosh.io/d/github.com/cloudfoundry/uaa-release?v=28 --sha1 f31f4358664cb067587143848a85f0e6f7a45485

Modify deployment manifest to use this release in addition to any other used releases:

releases:
- name: uaa
  version: "28"

Finally add needed deployment jobs and specify values for required properties.

Optionally download sha1: f31f4358664cb067587143848a85f0e6f7a45485 release tarball locally:

# ...or download it directly using curl
$ curl -L -J -O https://bosh.io/d/github.com/cloudfoundry/uaa-release?v=28

# or with wget...
$ wget --content-disposition https://bosh.io/d/github.com/cloudfoundry/uaa-release?v=28